CosmicGuard Down in London, UK.
Resolved
Sep 9, 2026 at 3:51am UTC
Services are recovering. We're monitoring as things stabilize.
Affected services
Updated
Sep 9, 2026 at 3:26am UTC
Our staff are on-site. We're working on resolution now. < 1H ETA
Affected services
Updated
Sep 9, 2026 at 2:19am UTC
We have identified a critical failure in the DDCL routing infrastructure hardware and have dispatched an emergency technician to remedy the issue immediately. We are working on this issue as quickly as possible.
Affected services
Updated
Sep 9, 2026 at 2:10am UTC
We have located what the issue is and are working on a resolution.
Affected services
Created
Sep 9, 2026 at 1:36am UTC
We're experiencing an outage in London, we're investigating and will update ASAP.
Affected services