Back to overview
Downtime
CosmicGuard Dallas PoP has gone offline.
Oct 25, 2024 at 06:15pm UTC
Resolved
Oct 25, 2024 at 06:41pm UTC
CosmicGuard has posted an update located here, we'll update that.
Affected services
Updated
Oct 25, 2024 at 06:23pm UTC
Servers are now starting to come back. We will post an update on what occurred.
Affected services
Updated
Oct 25, 2024 at 06:16pm UTC
We are aware and looking into it.
Affected services
Created
Oct 25, 2024 at 06:15pm UTC
Dallas location has gone offline.
Affected services