Back to overview
Degraded

CosmicGuard Network Flap

Nov 24 at 08:16am EST

Resolved
Nov 24 at 08:52pm EST

Official CosmicGuard report regarding the degraded performance:

This morning, a bug in the filtering code caused lag spikes and, in some instances, outages in specific locations. The issue was promptly identified and addressed, and throughout the day, we implemented several fixes to prevent it from happening again. These updates will not only resolve the problem but also enhance filtering performance on our end.

Updated
Nov 24 at 08:17am EST

All servers are now back online, we aren’t sure what occurred. We’re still investigating and will provide an update.

Created
Nov 24 at 08:16am EST

There was a network flip that disconnected CosmicGuard from all locations.